6.0.1

  • Released 12 May 2020

Bug Fixes

  • SRPLAT-1119 - Classes in scriptrunner-api/spi no longer consumable by dependent plugins

6.0.0

  • Released 06 May 2020

Updates

Groovy Upgrade

The version of Groovy used by ScriptRunner has been upgraded from 2.4.15 to 2.5.11. Improvements and new features (like additional AST transformations, or the new tap() method) shipped in Groovy 2.5 are now available to ScriptRunner users. See the Groovy 2.5 Release Notes for more information.

As with any dependency upgrade, breaking changes could potentially affect users' scripts. However, the breaking changes between Groovy 2.4 and 2.5 are relatively minor. The low-level nature of most of these breaking changes means they are unlikely to impact many ScriptRunner scripts if any.

Take a look at the list of breaking changes in the Groovy 2.5 Release Notes for further details.

IntelliJ Removal

This version removes all support for the IntelliJ IDEA plugin. See our previous deprecation announcement for our rationale and plans for the future.

Bug Fixes

  • SRPLAT-1092 - There is now DocLink support for absolute URLs

  • SRPLAT-1084 - The autocompletion window of the Script Console now closes correctly

  • SRCONF-1205 - ScriptRunner for Confluence is now compatible with the Confluence 7.5 EAP