5.4.50

  • Released 27 Feb 2019

New Features

  • [SRCONF-492] - ScriptRunner for Confluence users are now able to get notified when a page hasn't been updated for some time, therefore, ensuring your content is always relevant
  • [SRCONF-641] - ScriptRunner for Confluence users can now better integrate their custom codes with Comala Workflow App

Bug Fixes

  • [SRCONF-581] - Information box for Space Tools is incorrectly showing a blank message
  • [SRCONF-503] - Attempting to use the Confluence Search bar while in any of the ScriptRunner pages throws an error
  • [SRCONF-386] - Group Rest end point access in Lock content Macro is not restricted
  • [SRCONF-620] - Jackson-databind Vulnerabilities Assessment and Patch

5.4.47

  • Released 16 Jan 2019

Bug Fixes

5.4.36

  • Released 22 Oct 2018

Please read if you are using versions 5.4.16, 5.4.17 or 5.4.22

If you are currently using any of these versions, you may experience issues updating ScriptRunner if any of the dependent apps are enabled.

Dependent Apps include:

Suggested Workaround

You can avoid this issue simply by disabling dependent apps BEFORE you update ScriptRunner. You can then update ScriptRunner and re-enable your dependent apps. Once you update to 5.4.26 or later, you will no longer need to perform this workaround.

Other workarounds are available, please see this ticket for a full list of the documented workarounds. SRCONF-439.

Bug Fixes

  • [SRCONF-455] - Parameter button is missing in the Custom Script Macros. This fixes an issue where a change or changes to the custom script macro causes an error
  • [SRCONF-454] - Fixes issue where browsing server log files functionality is broken
  • Minor Security Updates

5.4.26

  • Released 18 Sep 2018
  • Compatible with Confluence 6.11.x

Updates

Important Instructions

If you are currently using either version 5.4.16 to 5.4.22 and you are moving to the latest release, you may experience issues updating if you are using ScriptRunner dependent plugins and they are enabled. There are workarounds documented as part of SRCONF-439.

Workaround

You can avoid this issue simply by disabling dependent plugins BEFORE you update ScriptRunner. You can then simply update ScriptRunner and re-enable your dependent plugins. Once you update to 5.4.26 or later, you will no longer need to perform this workaround.

New Features

  • [SRCONF-334] - Add a script to set page restrictions recursively
  • [SRCONF-314] - Create a new Rename Pages built-in script

Bug Fixes

  • [SRCONF-285] - JS and CSS files are not working, has to be inline
  • [SRCONF-445] - ScriptRunner macros not present in Macro Manager
  • [SRCONF-439] - ScriptRunner hanging on update

5.4.17

  • Released 10 August 2018

Bug Fixes

  • [SRCONF-420] - Bug in CQL Search Macro
  • [SRCONF-419] - Script Macros: Lazy macros are not loading
  • [SRCONF-338] - All the page trees should have a lazy select 2 and only when selected should fetch the page tree for that space

5.4.16

  • Released 20 July 2018
  • Compatible with Confluence 6.10.x

Bug Fixes

  • [SRCONF-385] - Permissions only allow selection of a single space
  • [SRCONF-384] - Broken macro after ScriptRunner update
  • [SRCONF-381] - Bulk Purge Trash does not work using the "All" checkbox
  • [SRCONF-380] - Inherit Permissions are not being maintained when upgrading to 5.4.9
  • [SRCONF-362] - Groups are not being lazily fetched
  • [SRCONF-341] - Example does not work
  • [SRCONF-284] - Built-in scripts pop-up dialogue not locked to the 'Space Tools' tab
  • [SRCONF-398] - Script macros : parameters cannot be edited after upgrade
  • [SRCONF-407] - ScriptConsole is showing up in the Space Admin Built-in Scripts

Due to an issue in the Space Admin Permissions we advise to navigate to that specific screen and verify if the permissions are correctly set for your instance.