5.3.35

  • Released 01 May 2018

Updates

Security Fixes

This update fixes a critical security vulnerability in ScriptRunner for Confluence discovered during an internal review. We strongly recommend all customers apply this update at their earliest opportunity. Further details will be released in the coming weeks as part of Adaptavist’s responsible disclosure approach.

All versions of ScriptRunner for Confluence are affected. Below are instructions on which version we recommend you upgrade to:

  • If you have Confluence 5.10.x or above, upgrade to 5.3.35

  • If you have Confluence 5.9.x, upgrade to 5.3.34

  • If you have Confluence 5.8.x, upgrade to 4.3.25

5.3.12

  • 05 April 2018
  • Compatible with Confluence 6.8.x

New Features

ScriptRunner Audit Logging Service Added

As a Confluence administrator you can now inspect script configuration changes from Confluence audit. For more information check Audit Logging.

Bug Fixes

  • [SRCONF-308] - Page with Lock Content macro does not save page after edit
  • [SRCONF-313] - Space field is eagerly fetching and should fetch lazy based on the user input
  • [SRCONF-306] - More reliable loading of ScriptRunner using MySQL
  • [SRPLAT-261] - ScriptRunner custom REST endpoints in Data Center only setup on one node
  • [SRCONF-265] - Copy Space Builtin Script Doesn't Copy all the properties

5.3.3

  • Released 12 Feb 2018
  • Compatible with Confluence 6.7.x

Bug Fixes

  • [SRCONF-272] - Lock Content is not pre-filling groups
  • [SRCONF-268] - Hide the panel "Advanced space Functionality" in space
  • [SRCONF-274] - Markdown Macro is not displaying Tables