
menulink macro
This macro creates a link to a specific Confluence feature or page relative to the current location in the wiki.

Each link destination abides by all applicable permissions - should the user not have sufficient permission to use the link, or simply be in a location where 
the link is not applicable, the body of the macro is returned un-linked (which is then usually hidden by the ).menuitem macro

Requirements

This macro requires Theme Builder 2.0 or above.

If you are using Theme Builder 3.0 or above, please consider using the  instead - it combines all the features of the compound-menuitem macro menuitem 
,  and this menulink macro in to a single macro which results in more concise wiki markup and significantly faster performance.macro menuicon macro

Usage

To display a text link use the following syntax:

{menulink:destination}Link Text{menulink}

To display link inside a menu (see ), use the following syntax:menubar macro

{menubar:id=example}
 {menuitem}{menulink:destination}Link Text{menulink}{menuitem}
{menubar}

Parameters

Please see .Links - Quick Reference

Caption Fields

Some link locations provide fields for captions which get automatically replaced when the links are displayed based on the state of the link location.

For example, the  field will be replaced with either "page" or "news" depending on whether you're looking at a page or a blog post.%page%

{menulink:edit}Edit this %page%{menulink}

Field Link Destinations Notes

%page% information, edit, remove, favourite, 
favouritespace, watch, watchspace, watchpage

Displays either "page", "news" or "space" as applicable to the content you are 
currently viewing.

%count% spaceattachments, children, comments, 
pageattachments, viewattachments

Displays the number of attachments, children or comments as applicable to the 
link location.

%user% profile, userspace Displays the users full name.

%space%, %
Space%

activity Displays "space" or "site" - the %Space% field capitalises the first letter, eg. 
"Space" or "Site".

%add% favourite, favouritespace, watch, watchspace, 
watchpage

Displays "Add" or "Remove" depending on whether the content is in your 
favourites or watched.

%
watching%, 
%watch%

watch, watchspace, watchpage Displays "Watching" or "Watch" (%watching%), "Watch" or "Unwatch" (%watch) 
depending on whether you are watching the content.

Link Destinations

The following link destinations can be used in the menulink macro and also the .compound-menuitem macro
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The  column denotes which version of Theme Builder is required.Ver

Account management

Destination Default Location Notes Builder 
Ver

Feature 
Of

login View > Account > Login If the user is logged out, this will take them to the login screen 2.0.0 Confluence

logout View > Account > Logout If the user is logged in, this will take them to the logout screen 2.0.0 Confluence

profile View > Account > Preferences: 
<name>

If the user is logged in, this will take them to their personal profile screen 2.0.0 Confluence

userspace View > Account > Personal Space Displays the users' personal space if they have one, otherwise it displays their 
personal profile

2.0.0 Confluence

signup View > Account > Sign-up Displays the user sign-up screen (if public sign-up is enabled in General 
Configuration)

2.0.2 Confluence

Community Features

Destination Default Location Notes Builder 
Ver

Feature Of

inviteothers     3.0 Invite Plugin

invitelist     3.0 Invite Plugin

invite View > Invite Friends   3.0 Invite Plugin

customusermanagement Edit > Administration > User 
Management...

Displays screen for editing the user group associated 
with current space.

2.0.8 Custom Space User 
Management

space-socialbookmarks View > Other Pages > Bookmarks Displays a list of bookmarks for the current space. 3.0 Social Bookmarking Plugin

review Edit > New > Review... Adds a new review for the current page. 2.0.8 Mark for Review Plugin

Web Feeds

Destination Default Location Notes Builder 
Ver

Feature 
Of

podcastpage Edit > Podcast Settings... Configures Podcast settings for a page. 2.0.8 Podcast 
Plugin

podcastnews Edit > Podcast Settings... Configures Podcast settings for a blog post (news). 2.0.8 Podcast 
Plugin

podcastchannels View > Other Pages > Podcasts Displays Podcast channels screen for a space (which also allows channels 
to be edited).

2.0.8 Podcast 
Plugin

RSS View > Other Pages > RSS Feed 
Builder

Displays the RSS Feed Builder 2.0.0 Confluence

Folksonomy (Labels/Tags)

Destination Default Location Notes Builder Ver Feature Of

labels View > Other Pages > Labels Displays the labels within a space or global labels if used outside a Space 2.0.0 Confluence

label
globalLabel

Interest Management

Destination Default Location Notes Builder 
Ver

Feature 
Of

favourite View > This Page > Add/remove 
favourite

Adds or removes the current page/news/space to or from personal favourites. See 
also: builder-favicon macro

2.0.0 Confluence
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watch View > This Page > Watch this 
page/news/space

Toggles email notifications when current page/news/space is changed 2.0.0 Confluence

pagewatcher View > This Page > Watchers Displays a list of people watching the current page, editable by admins. 3.0 Community 
Bubbles

newswatcher View > This Page > Watchers Displays a list of people watching the current blogpost, editable by admins. 3.0 Community 
Bubbles

pagefavourites View > This Page > Favourites Displays a list of people who have marked the page as their favourite, editable by 
admins.

3.0 Community 
Bubbles

newsfavourites View > This Page > Favourites Displays a list of people who have marked the blogpost as their favourite. 3.0 Community 
Bubbles

favouritespace   Adds or removes the current space from the logged in users' favourites. 3.0 Confluence

watchspace   Toggles email notifications for the space for the logged in user. 3.0 Confluence

watchpage   Toggles email notifications for the current page or blogpost for the logged in user. 
See also: builder-watchicon macro

  Confluence

activity View > Other Pages > Usage 
Statistics

Links to the activity graphs for the current space or entire site (depending on 
current location in wiki).

  Activity 
Plugin

Content Creation

Destination Default Location Notes Builder 
Ver

Feature Of

newcomment Edit > New > 
Comment...

Creates a new comment on a page or news item (blog post) within a Space 2.0.0 Confluence

newnews Edit > New > News... Creates a new news item (blog post) within a Space 2.0.0 Confluence

newpage Edit > New > Page... Creates a new page within a Space 2.0.0 Confluence

newspace Edit > New > Space... Creates a new Space 2.0.0 Confluence

addbookmark Edit > New > 
Bookmark...

Links to the "Add Bookmark" screen. 3.0 Social Bookmarking 
Plugin

editgridaddbook Edit > New > 
Spreadsheet...

Adds a new editable spreadsheet to the page. 2.0.8 Edit Grid

notationguide   Links to the notation guide. You can use other parameters, such as target, to 
launch it in a new window.

3.0 Confluence

Content Management

Destination Default Location Notes Builder 
Ver

Feature Of

copy Edit > Copy this Page... Creates an editable copy of a page 2.0.0 Confluence

edit Edit > Edit this Page/News... Edits the current page or news item 2.0.0 Confluence

remove Edit > Remove this Page
/News...

Deletes (after confirmation) the current page or news item 2.0.0 Confluence

editinword Edit > Edit in Word Edits the current page in MS Word. 3.0 WordDAV 
Plugin

addgliffydiagram Edit > New > Diagram... Adds a new Gliffy diagram to a wiki page. 2.0.8 Gliffy Plugin

pageattachments Edit > Attachments Displays the attachments for a page or news item if you have add-attachment 
permission

2.0.0 Confluence

viewattachments   Displays the attachments for a page or news item 3.0 Confluence

Content Exporting

These options allow you to export content in different formats.

Destination Default Location Notes Builder 
Ver

Feature 
Of
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1.  

2.  

emailpage View > This Page > Email to a 
friend...

Allows the user to email the page to a friend. 2.0.7 Mail Page 
Plugin

exportMail View > This Page > Export to 
Wiki Page

When viewing a mail message in the space mail archive, this will export that message 
(including attachments) to a new, editable wiki page

2.0.7 Theme 
Builder

exportPDF View > This Page > Export to 
Adobe Acrobat (PDF)

Exports the page (and in some versions of Confluence, a blog post) to a PDF file 2.0.0 Confluence

exportWord View > This Page > Export to 
Microsoft Word

Exports the page (and in some versions of Confluence, a blog post) to a Word document 2.0.0 Confluence

Display Mode

Destination Default Location Notes Builder 
Ver

Feature 
Of

information View > This Page > Page 
Information

Displays information for a page or blog post 2.0.0 Confluence

normalView View > This Page > Normal 
view

The normal view of a page.

 

 1

 

 

2.0.0 Confluence

printableView View > This Page > 
Printable view

The print preview of any page. If a sidebar is set to be "collapsed by default" it will not 
appear in the print preview.

 

 2

 

 

2.0.0 Confluence

pageView View > This Page > View 
Page

When viewing attachments or page information, this will return you to the normal view of 
the page.

3.0 Confluence

information View > This Page > Page 
Information

Displays page information such as recent changes, author, incoming links, etc. 2.0.0 Confluence

In Theme Builder 2.x this link will return you to the actual page if viewing attachments or information screens for a page. In Theme Builder 3.0 and 
 above, this will display the normal view of whatever you are currently looking at (useful for returning from printable view).     

In Theme Builder 2.x the printable view simply removes the menu and navigation bars. In Theme Builder 3.0 and above the printable layout 
 (which can be fully customised in  will be displayed.Layout Manager     

Visibility Settings

Destination Default Location Notes Builder Ver Feature Of

children View > Show Children Toggle the display of the builder-children macro 2.0.0 Theme Builder

comments View > Show Comments Toggle the display of the builder-comments macro 2.0.0 Theme Builder

toggleVisibility   Shows or hides a HTML tag (and it's contents) based on it's HTML id (see examples). 2.0.7

toggleSidebar

General Navigation

Destination Default Location Notes Builder 
Ver

Feature 
Of

dashboard View > Other Pages > dashboard Site dashboard 2.0.0 Confluence

mail View > Mail If a Space has mail in it's mail archive, this will display the mail archive 2.0.0 Confluence

news View > Other Pages > News Displays the recent news within a Space 2.0.0 Confluence

recent View > Other Pages > Recent 
Updates

Displays the list of recent updates within a Space 2.0.0 Confluence

https://docs.adaptavist.com/display/Builder/Layout+Manager
https://docs.adaptavist.com/display/Builder/builder-children+macro
https://docs.adaptavist.com/display/Builder/builder-comments+macro


history View > Account > History Displays the history of visited pages, for the current user, in a new window 2.0.0 Confluence

search   Links to the search screen (defaulting to searching the current space where 
applicable).

2.0.0 Confluence

index View > Other Pages > Index Displays the alphabetical index of content in a Space 2.0.0 Confluence

spaceattachments View > Other Pages > 
Attachments

Displays the attachments index within a Space 2.0.0 Confluence

people View > Other Pages > People 
Directory

Displays the people directory.   Confluence

Hierarchical Navigation

Destination Default 
Location

Notes Builder 
Ver

Feature 
Of

home View > Other 
Pages > 
Home Page

If used within a Space, this takes the user to the space home page. If used anywhere else, the site home 
page is shown. The site home page is either the user's homepage (if set in their profile), the site homepage 
(if set in General Configuration) or the Dashboard (default)

2.0.0 Confluence

next   Links to the next sibling page. 3.0 Theme 
Builder

prev   Links to the previous sibling page. 3.0 Theme 
Builder

parent   Links to the parent of the current page. 3.0 Theme 
Builder

first   Links to the first sibling page. 3.0 Theme 
Builder

last   Links to the last sibling page. 3.0 Theme 
Builder

firstchild   Links to the first child page. 3.0 Theme 
Builder

lastchild   Links to the last child page. 3.0 Theme 
Builder

map View > Other 
Pages > Site 
Map

Displays the tree view of hierarchical pages (with current page selected if applicable) within a Space. 2.0.0 Confluence

Custom Links

Destination Default 
Location

Notes Builder 
Ver

Feature 
Of

custom   Allows you to specify a custom URL. This is often useful if you want an external web page to launch in a new 
window because you can combine it with the "target" parameter.

  Theme 
Builder

webui   Displays a "Web UI" link (some plugins use these to add additional navigation, etc). See Examples for more 
details. The next section (third-party) lists some inbuilt webui aliases for popular plugins.

2.0.8 Confluence

wikipage   Links to a wiki page, the page being defined using the  parameter (and optionally the  parameter page space
if the page is in a different space.

3.0 Confluence

Theme Configuration

Destination Default Location Notes Builder 
Ver

Feature 
Of

configuretheme Edit > Administration > Configure 
Theme

Displays the theme configuration page (Builder 2.x) or  Layout Chooser
(Builder 3.0 and above).

2.0.0 Theme 
Builder

colourscheme Edit > Administration > Colour 
Scheme

Displays the space or global (as applicable to current location) colour scheme 
editor.

3.0 Confluence

chooselayout Edit > Administration > Choose 
Layout

Displays the .Layout Chooser 3.0 Theme 
Builder

managelayouts Edit > Administration > Manage 
Layouts

Displays the .Layout Manager 3.0 Theme 
Builder

themeadmin Edit > Administration > Theme 
Administration

Displays the  screen.Theme Administration 3.0 Theme 
Builder
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use-layout   Allows selection of a different layout. See examples and also .use-layout macro 3.0 Theme 
Builder

Administration

Destination Default Location Notes Builder Ver Feature Of

advanced Edit > Administration > Advanced Displays the "advanced" screen 2.0.0 Confluence

siteadmin Edit > Administration > Site Administration Displays the Administration Console 2.0.0 Confluence

spaceadmin Edit > Administration > Space Administration Displays teh Space administration screen 2.0.0 Confluence

admingliffy Edit > Admiinstration > Gliffy... Links to the Gliffy administration screen. 2.0.8 Gliffy

reviewreport Edit > Administration > Reviews Displays review report for the space. 2.0.8 Mark for Review Plugin

reviewspaceconfig Edit > Administration > Review - Space Config Space-level configuration for Reviews. 2.0.8 Mark for Review Plugin

reviewglobalconfig Edit > Administration > Review - Admin Config Global configuration for Reviews. 2.0.8 Mark for Review Plugin

inviteothersadmin Edit > Administration > Invite Others   3.0 Invite Plugin

invitelistadmin Edit > Administration > Invite List   3.0 Invite Plugin

globaltemplates Edit > Administration > Global Templates Displays the global templates 2.0.0 Confluence

spacetemplates Edit > Administration > Space Templates Displays the templates within a Space 2.0.0 Confluence

Examples

You can create a link to the dashboard as follows:

{menulink:dashboard}Go to the dashboard{menulink}

When you are adding links in menus, wrap them in the :menuitem macro

{menuitem}{menulink:dashboard}Go to the dashboard{menulink}{menuitem}

You can link to a space by using a combination of the  location and the  parameter:home space

{menulink:home|space=foo}Go to the home page of the foo space{menulink}

That will link to the home page of a Space with a key of "foo".

This is really useful because if someone renames the home page this link will still work!

You can link to a feature in another space as follows:

{menulink:map|space=wibble}Wibble Site Map{menulink}

This would show the site map in the Space with a key of "wibble", regardless of where you are in your site.

To add tooltips and access keys, use the following notation:

https://docs.adaptavist.com/display/Builder/use-layout+macro
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{menulink:newcomment|accesskey=c|tooltip=Add comment}Add a comment...{menulink}

If a menulink is not applicable (eg. user doesn't have privilages or the link does not relate to the current location within your site, etc) 
then the body text of the link will be output unlinked.

For example, if a user does not have comment privileges, then they would see the link shown in the previous example as:

Add a comment...

Obviously, that's not very useful so you want to hide inactive menu links. To do this, use the  which will hide it's menuitem macro
body content if there are no links in it:

{menuitem:flat=true}{menulink:newcomment}Add a comment...{menulink}{menuitem}

If the body of the  doesn't contain a link, it will not be shown.menuitem macro

You can open the link destination in a specific frame or window using the  parameter:target

{menulink:map|target=_blank}Open site map in new window{menulink}

You can toggle the visibility of any HTML tag with a unique id using the code below:

{div:id=visdemo}*This is a div tag with id of "visdemo" that you can show or hide using the 
link below.*{div}

{menulink:toggleVisibility|toggle=visdemo}Toggle the text above{menulink}

As you can see, the div tag has been given a HTML id - the raw HTML looks like this:

<div id="visdemo"> ... <div>

And the "target" parameter in the menulink macro states what id will be toggled.

If you want the tag to initially be hidden, use the "display:none" CSS style:

{div:id=visdemo1|style=display:none;}*This is a div tag with id of "visdemo1" that you can 
show or hide using the link below.*{div}

{menulink:toggleVisibility|toggle=visdemo1}Show/hide the text above{menulink}

The div tag will now be output with a style attribute like this:

<div id="visdemo1" style="display:none;"> ... <div>

Note that we've changed the id from "visdemo" to "visdemo1" - that's because a HTML id must be unique to the entire web page. If 
there are two or more occurrences of the same id, the results can be very unpredictable so make sure to use unique id's.

To add tooltips and access keys, use the following notation:

https://docs.adaptavist.com/display/Builder/menuitem+macro
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{menulink:custom|link=http://www.domain.com/path/resource.file}Other{menulink}

Web UI links are a feature of Confluence plugins that allow them to add additional navigation to the default themes.

However, because Theme Builder displays navigation in a significantly different format, we can't display those links by default 
otherwise we'd end up with duplicate and confusing navigation in the default menus.

 Web UI link support was added in Theme Builder 2.0.8 and above.

Before adding Web UI links as shown below, please check the table above the Examples section on this page which lists a number 
of aliases for popular third party plugins.

To add Web UI links to Theme Builder meuns, use the following syntax:

{menulink:webui|location=XXXX|key=YYYY}webui link{menulink}

For example, here's the markup used for the podcasting plugin:

Podcast Page Tab

{menulink:webui|location=system.page|key=podcast-episode-page-webui}Edit Podcast{menulink}

Podcast News Item Tab

{menulink:webui|location=system.news|key=podcast-episode-blogpost-webui}Edit Podcast{menulink}

Podcast Channels Space Tab

{menulink:webui|location=system.space|key=space-podcast-channel-webui}Podcast Channels
{menulink}

Note: There are aliases for these links in the table further up the page, the links shown above are just to illustrate how to manually 
construct those links.

If you don't specify any link text (eg. "Edit Podcast") then the default text supplied by the plugins' Web UI link will be used.

 Important
Many third party plugins don't do strict checking of the mode and context to determine whether a Web UI link should be displayed. 
Because Theme Builder can display Web UI links in any area of Confluence, you might need to use the  or builder-show macro builde

 to show/hide Web UI links that start appearing in too many places.r-hide macro

If you need a technical explanation as to why this is the case, or any help with working with Web UI links in third party plugins, 
please contact our support desk.

When using the menulink inside a menu, it needs to be wrapped in the menuitem macro, eg:

{menuitem}{menulink:webui|location=system.space|key=space-podcast-channel-webui}Podcast 
Channels{menulink}{menuitem}

Hints and Tips

You can create keyboard shortcuts by adding empty menulinks to a panel in builder (eg. title or footnotes panel, etc), for example:

{menulink:edit|tooltip=Edit this content|accesskey=e}{menulink}

This would add the keyboard shortcut "Alt+E" to all screens that can be edited (eg. blogposts, pages, etc). The shortcut would only be available if the 
current user has sufficient privileges to edit the page, etc.

https://docs.adaptavist.com/display/Builder/builder-show+macro
https://docs.adaptavist.com/display/Builder/builder-hide+macro
https://docs.adaptavist.com/display/Builder/builder-hide+macro

	menulink macro

