compound-menuitem macro

Error rendering macro 'toc'

[com.ctc.wstx.exc.WstxLazyException] com.ctc.wstx.exc.WstxParsingException: Undeclared namespace prefix "footnotes" at [row,col

{unknown-source}]: [88,151]

Description

This macro creates a link to a specific Confluence feature or page relative to the current location in the wiki.

The macro combines the features of the menuitem macro, menulink macro and menuicon macro resulting in cleaner syntax and a three fold performance
increase.

Each link destination abides by all applicable permissions - should the user not have sufficient permission to use the link, or simply be in a location where
the link is not applicable, the body of the macro is returned un-linked (which is then usually hidden by the menuitem macro).

Requirements

This macro requires Theme Builder 3.0 or above.

Usage

{ compound- nenui t em | i nkt ype| capti on=t ext | i con=i con_nane}

Parameters
Property Required Default Notes Ver
default o The destination to link to (see list below) 3.0
e 0 The link text to be displayed to the user. 3.0
space 0 current space | Optionally set the space to which the link relates. 3.0
page Q current page Optionally set the page to which the link relates, eg. when using the "newpage" destination you can define the parent page with this = 3.0
parameter.
parent 0 space When using the "exportMail* destination, this defines the page that will be the parent of the new page containing the exported mail 3.0
homepage message.
link 0 When using the "custom” destination (see examples) this is the URL to link to. 3.0
toggle 0 When using the "toggleVisibility" destination (see examples) this is the HTML id of the tag to show/hide. 3.0
tooltip 0 The tooltip to display when the mouse hovers over the link (max: 77 chars for cross-platform compatibility) 3.0
accesskey Q An optional shortcut key for the link which can be any alphanumeric character 3.0
target 0 current An optional target window or frame in which to load the link destination. 3.0
browser
window
class 0 Optional HTML classes to associated with the hyperlink. 3.0
hideanon | € false Whether to hide the link from anonymous users: 3.0
® false - don't hide from anonymous users (default)
® true - always hide from anonymous users, even if they have privileges to use the link
rel 0 automatic The "rel" attribute to assign to the link. Many links get an automatic rel attribute (eg. rel="index" for the index link) and also 3.0

"nofollow" rels to prevent search engines following links that alter content, etc.
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icon 0
imginside 0

size 0
layout

latch 0

]

item 0
flag °
notflag 0

none the icon to use as one of SPACEKEY:pagename”filename.ext/custom url/inbuilt icon (use 'noicon’ to prevent an icon being 3.0
displayed)
false Defines whether the icon (if present) should be within the link tag or outside it. This is useful when displaying just an icon link on the ' 3.0

main menu bar.

® false - icon is outside the link tag (default)

® true - icon is inside the link tag

16 When used with the compound-menuitem macro, defines the pixel size (same for width and height) of the icon if shown. 3.0
When using the use-layout location, defines the layout ID to use. 3.0
false When using the use-layout location, determines whether the layout should be used temporarily for the resulting page view or 3.0

latched for all subsequent page views.

* false - don't latch the layout (default)
® true - latch the layout so it's used for subsequent page views

3.0
The macro is rendered only if one or more of the specified flags are set. See Working with Flags for more details. 3.3.6
The macro is rendered only if none of the specified flags are set. See Working with Flags for more details. 3.3.6

Caption Fields

Some link locations provide fields for captions which get automatically replaced when the links are displayed based on the state of the link location.

For example, the %page%field will be replaced with either "page" or "news" depending on whether you're looking at a page or a blog post.

{conpound- menui tem edi t| caption=Edit this %age%

Field

%page%

%count%

%user%

%space%, %
Space%

Y%add%

%watching%,
Y%watch%

Link Destinations

information, edit, remove, favourite, favouritespace,
watch, watchspace, watchpage

spaceattachments, children, comments,
pageattachments, viewattachments

profile, userspace

activity

favourite, favouritespace, watch, watchspace,
watchpage

watch, watchspace, watchpage

Link Destinations

Notes

Displays either "page”,
viewing.

news" or "space" as applicable to the content you are currently
Displays the number of attachments, children or comments as applicable to the link
location.

Displays the users full name.

Displays "space" or "site" - the %Space% field capitalises the first letter, eg. "Space" or
"Site".

Displays "Add" or "Remove" depending on whether the content is in your favourites or
watched.

Displays "Watching" or "Watch" (%watching%), "Watch" or "Unwatch" (%watch)
depending on whether you are watching the content.

The following link destinations can be used in the compound-menuitem macro.

The Ver column denotes which version of Theme Builder is required.

Destination Default Location Notes Builder Feature
Ver of
login View > Account > Login If the user is logged out, this will take them to the login screen 3.0 Confluence
logout View > Account > Logout If the user is logged in, this will take them to the logout screen 3.0 Confluence
profile View > Account > Preferences: If the user is logged in, this will take them to their personal profile screen 3.0 Confluence
<name>
userspace View > Account > Personal Displays the users' personal space if they have one, otherwise it displays their = 3.0 Confluence

Space personal profile
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signup View > Account > Sign-up Displays the user sign-up screen (if public sign-up is enabled in General 3.0 Confluence
Configuration)
Destination Default Location Notes Builder Feature Of
Ver
inviteothers 3.0 Invite Plugin
invieleh 3.0 Invite Plugin
invie View > Invite Friends 3.0 Invite Plugin
customusermanagement Edit > Administration > User D!splays screen for editing the user group associated | 3.0 Custom Space User
Management... with current space. Management
space-socialbookmarks View > Other Pages > Displays a list of bookmarks for the current space. 3.0 Soual Bookmarking
Bookmarks Plugin
vl Edit > New > Review... Adds a new review for the current page. 3.0 Mark for Review Plugin
Destination Default Location Notes Builder Feature
Ver Of
podcastpage Edit > Podcast Settings... Configures Podcast settings for a page. 3.0 Podqast
Plugin
podcastnews Edit > Podcast Settings... Configures Podcast settings for a blog post (news). 3.0 Eﬁjdg(;sst
podcastchannels View > Other Pages > Podcasts | Displays Podcast _channels screen for a space (which also allows 3.0 Podgast
channels to be edited). Plugin
RSS View > Other Pages > RSS Feed ' Displays the RSS Feed Builder 3.0 Confluence
Builder
Destination Default Location Notes Builder Ver Feature Of
labels View > Other Pages > Labels ' Displays the labels within a space or global labels if used outside a Space ' 3.0 Confluence
label
globalLabel
Destination Default Location Notes Builder Feature
Ver Of
EVANTE View > This Page > Add Adds or removes the current page/news/space to or from personal 3.0 Confluence
/remove favourite favourites. See also: builder-favicon macro
e View > This Page > Watch this | Toggles email notifications when current page/news/space is changed 3.0 Confluence
page/news/space
pagewatcher View > This Page > Watchers Displays a list of people watching the current page, editable by admins. 3.0 Community
Bubbles
EEEEET View > This Page > Watchers Displays a list of people watching the current blogpost, editable by admins. 3.0 Community
Bubbles
pagefavourites View > This Page > Favourites D|§p|ays a list of_ people who have marked the page as their favourite, 3.0 Community
editable by admins. Bubbles
S EVEIHES View > This Page > Favourites  Displays a list of people who have marked the blogpost as their favourite. 3.0 Community
Bubbles
favouritespace Adds or removes the current space from the logged in users' favourites. 3.0 Confluence
watchspace Toggles email notifications for the space for the logged in user. 3.0 Confluence
Toggles email notifications for the current page or blogpost for the logged in 3.0 Confluence
watchpage b :
user. See also: builder-watchicon macro
activity View > Other Pages > Usage Links to the activity graphs for the current space or entire site (depending on Activity
Statistics current location in wiki). Plugin
Destination Default Location Notes Builder Feature Of

Ver
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A EERIE Edit > New > Comment... = Creates a new comment on a page or news item (blog post) withina ' 3.0 Confluence
Space
RS Edit > New > News... Creates a new news item (blog post) within a Space 3.0 Confluence
newpage Edit > New > Page... Creates a new page within a Space 3.0 Confluence
newspace Edit > New > Space... Creates a new Space 2.0.0 Confluence
ceilealaiErk Edit > New > Bookmark... | Links to the "Add Bookmark" screen. 3.0 gﬁ%ﬁl Bookmarking
editgridaddbook Edit > New > Adds a new editable spreadsheet to the page. 3.0 Edit Grid
Spreadsheet...
Destination Default Location Notes Builder Feature
Ver of
copy Edit > Copy this Page... Creates an editable copy of a page 3.0 Confluence
edit Edit > Edit this Page Edits the current page or news item 3.0 Confluence
INews...
CETEE Edit > Remove this Page Deletes (after confirmation) the current page or news item 3.0 Confluence
INews...
editond Edit > Edit in Word Edits the current page in MS Word. 3.0 Won_jDAV
Plugin
addgliffydiagram Edit > New > Diagram... Adds a new Gliffy diagram to a wiki page. 3.0 Gliffy Plugin
pageattachments Edit > Attachments Displays the atta(;hments for a page or news item if you have add- 3.0 Confluence
attachment permission
e EE Displays the attachments for a page or news item 3.0 Confluence
These options allow you to export content in different formats.
Destination Default Location Notes Builder Feature
Ver Of
emailpage V_iew > This Page > Email to a = Allows the user to email the page to a friend. 3.0 Mail _Page
friend... Plugin
exportMail View > This Page > Exportto = When viewing a mail message in the space mail archive, this will export that 3.0 Theme
Wiki Page message (including attachments) to a new, editable wiki page Builder
View > This Page > Export to Exports the page (and in some versions of Confluence, a blog post) to a PDF file 3.0 Confluence
exportPDF
Adobe Acrobat (PDF)
View > This Page > Export to Exports the page (and in some versions of Confluence, a blog post) to a Word 3.0 Confluence
exportWord )
Microsoft Word document
Destination Default Location Notes Builder Feature
Ver Of
infoLmation View > This Page > Page Displays information for a page or blog post 3.0 Confluence
Information
e View > This Page > The normal view of a page. 3.0 Confluence
Normal view
A a View > This Page > The print preview of any page. If a sidebar is set to be "collapsed by default" it will 3.0 Confluence
printableView N : . . ;
Printable view not appear in the print preview.
pageView View > This Page > View When viewing attachments or page information, this will return you to the normal 3.0 Confluence
Page view of the page.
EREeR View > This Page > Page Displays page information such as recent changes, author, incoming links, etc. 3.0 Confluence
Information
Destination Default Location Notes Builder Feature
Ver Oof
q View > Show Children ' Toggle the display of the builder-children macro 3.0 Theme
children N
Builder
CEENS View > Show Toggle the display of the builder-comments macro 3.0 Tha_sme
Comments Builder
Shows or hides a HTML tag (and it's contents) based on it's HTML id (see 3.0

toggleVisibility

examples).
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toggleSidebar

Destination Default Location Notes
dashboard View > Other Pages > Site dashboard
Dashbaord
el View > Mail If a Space has mail in it's mail archive, this will display the mail archive
S View > Other Pages > News Displays the recent news within a Space
e View > Other Pages > Recent Displays the list of recent updates within a Space
Updates
history View > Account > History Displays the history of visited pages, for the current user, in a new
window
earen Links to the search screen (defaulting to searching the current space
where applicable).
Ny View > Other Pages > Index Displays the alphabetical index of content in a Space
spaceattachments View > Other Pages > Displays the attachments index within a Space
Attachments
View > Other Pages > People Displays the people directory.
people ]
Directory
Destination Default Notes
Location
(GG View > If used within a Space, this takes the user to the space home page. If used anywhere else, the site
Other Pages | home page is shown. The site home page is either the user's homepage (if set in their profile), the
> Home site homepage (if set in General Configuration) or the Dashboard (default)
Page
E Links to the next sibling page.
prev Links to the previous sibling page.
parent Links to the parent of the current page.
first Links to the first sibling page.
|ast Links to the last sibling page.
firstchild Links to the first child page.
|astchild Links to the last child page.
map View > Displays the tree view of hierarchical pages (with current page selected if applicable) within a Space.
Other Pages
> Site Map
Destination Default Notes
Location
GUSHEnD Allows you to specify a custom URL. This is often useful if you want an external web page to launch
in a new window because you can combine it with the "target" parameter.
oo Displays a "Web UI" link (some plugins use these to add additional navigation, etc). See Examples
for more details. The next section (third-party) lists some inbuilt webui aliases for popular plugins.
wikipage Links to a wiki page, the page being defined using the page parameter (and optionally the space
parameter if the page is in a different space.
Destination Default Location Notes

configuretheme Theme

colourscheme
Scheme

Edit > Administration > Configure

Edit > Administration > Colour

Displays the theme configuration page (Builder 2.x) or Layout Chooser
(Builder 3.0 and above).

Displays the space or global (as applicable to current location) colour
scheme editor.

Builder
Ver

3.0

3.0

3.0

3.0

3.0

3.0

3.0

3.0

Builder
Ver

3.0

3.0

3.0

3.0

3.0

3.0

3.0

3.0

3.0

Builder
Ver

3.0

3.0

3.0

Builder
Ver

3.0

3.0

Feature
Of

Confluence

Confluence

Confluence

Confluence

Confluence

Confluence

Confluence

Confluence

Confluence

Feature
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Confluence

Theme
Builder

Theme
Builder

Theme
Builder

Theme
Builder

Theme
Builder

Theme
Builder

Theme
Builder

Confluence

Feature
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Theme
Builder

Confluence
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Feature
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Theme
Builder

Confluence
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chooselayout Edit > Administration > Choose Displays the Layout Chooser. 3.0 Theme

Layout Builder
managelayouts Edit > Administration > Manage Displays the Layout Manager. 3.0 Th_eme
Layouts Builder
e eadmin Edit > _Admi_nistration > Theme Displays the Theme Administration screen. 3.0 Th_eme
Administration Builder
aadh Allows selection of a different layout. See examples and also use-layout 3.0 Theme
-layout €
macro. Builder
Destination Default Location Notes Builder Ver Feature Of
hEREE] Edit > Administration > Advanced Displays the "advanced" screen 3.0 Confluence
StcErmin Edit > Administration > Site Administration Displays the Administration Console 3.0 Confluence
spaceadmin Edit > Administration > Space Administration ' Displays teh Space administration screen | 3.0 Confluence
admingliffy Edit > Admiinstration > Gliffy... Links to the Gliffy administration screen. ' 3.0 Gliffy
reviewreport Edit > Administration > Reviews Displays review report for the space. 3.0 Mark for Review Plugin
reviewspaceconfig Edit > Administration > Review - Space Config = Space-level configuration for Reviews. 3.0 Mark for Review Plugin
reviewglobalconfig Edit > Administration > Review - Admin Config = Global configuration for Reviews. 3.0 Mark for Review Plugin
e Edit > Administration > Invite Others 3.0 Invite Plugin
nyitelscadmin Edit > Administration > Invite List 3.0 Invite Plugin
globaltemplates Edit > Administration > Global Templates Displays the global templates 3.0 Confluence
Edit > Administration > Space Templates Displays the templates within a Space 3.0 Confluence

spacetemplates

Examples

A menu link to a wiki page can be created by setting the pagetyoe to wikipage and setting the page parameter to the destination
page. Like this:

{conmpound- nmenui t em wi ki page| page=<your _page>}

if the page is in a different space include the space parameter.
Like so:

{conmpound- nmenui t em wi ki page| space=<your _space>| page=<your _page>}
You can create a link to the dashboard as follows:

{ compound- nenui t em dashboar d| capti on=Co to the dashboard}

You can link to a space by using a combination of the hone location and the space parameter:
{ conpound- menui t em hore| space=f oo| capti on=CGo to the home page of the foo space}

That will link to the home page of a Space with a key of "foo".

This is really useful because if someone renames the home page this link will still work!

You can link to a feature in another space as follows:
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{ compound- nenui t em map| space=w bbl e| capti on=W bbl e Site Map}

This would show the site map in the Space with a key of "wibble", regardless of where you are in your site.

To add tooltips and access keys, use the following notation:

{ compound- menui t em newcoment | accesskey=c| t ool ti p=Add conment | capti on=Add a comment. ..}

) this does not appear to be working at the momment

If a compound-menuitem is not applicable (eg. user doesn't have privilages or the link does not relate to the current location within
your site, etc) then the body text of the link will be output unlinked.

For example, if a user does not have comment privileges, then they would see the link shown in the previous example as:
Add a comment...

Obviously, that's not very useful so you want to hide inactive menu links. To do this, use the menuitem macro which will hide it's
body content if there are no links in it:

{ compound- nenui t em newconmment | f| at =t rue| capti on=Add a conmment...}

If the body of the menuitem macro doesn't contain a link, it will not be shown.

You can open the link destination in a specific frame or window using the target parameter:

{ conmpound- nenui t em map| t ar get =_bl ank| capti on=Cpen site map i n new w ndow}

Which results in:

Unknown macro: {compound-menuitem}

I\ There is a bug in Builder 2.0.1 - please don't use this link destination until further notice as it doesn't work.

You can toggle the visibility of any HTML tag with a unique id using the code below:

{div:id=visdenp}*This is a div tag with id of "visdemd" that you can show or hide using the
I'i nk bel ow. *{di v}

{menul i nk: toggl eVi si bility|target=visdeno}Toggl e the text above{menulink}

As you can see, the div tag has been given a HTML id - the raw HTML looks like this:

<div id="visdemo"> ... <div>

And the "target" parameter in the menulink macro states what id will be toggled.
The result:
Unknown macro: {div}

Thic ic a div tanwith id af "viedemo" that you can show or hide using the link below.
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Unknown macro: {menulink}
Toggle the text above

If you want the tag to initially be hidden, use the "display:none" CSS style:

{div:id=visdenpl| styl e=di spl ay: none;}*This is a div tag with id of "visdenpl" that you can
show or hide using the link bel ow *{div}

{menul i nk: toggl eVi si bi lity]|target=visdenpl} Show hide the text above{nenulink}

The div tag will now be output with a style attribute like this:

<div id="visdenpl" style="display:none;"> ... <div>

Note that we've changed the id from "visdemo" to "visdemol" - that's because a HTML id must be unique to the entire web page. If
there are two or more occurrences of the same id, the results can be very unpredictable so make sure to use unique id's.

The result (it starts hidden so click the link to see it):
Unknown macro: {div}

[ S S T P R S R T

“~demol" that you can show or hide using the link below.
Unknown macro: {menulink}

Showr/hide the text above

To add tooltips and access keys, use the following notation:

{conpound- menui t em cust on] I i nk=htt p: // ww. domai n. con? pat h/ resource. fil e| capti on=C her}

Web Ul links are a feature of Confluence plugins that allow them to add additional navigation to the default themes.

However, because Theme Builder displays navigation in a significantly different format, we can't display those links by default
otherwise we'd end up with duplicate and confusing navigation in the default menus.

0 Web Ul link support was added in Theme Builder 2.0.8 and above.

Before adding Web Ul links as shown below, please check the table above the Examples section on this page which lists a number
of aliases for popular third party plugins.

To add Web Ul links to Theme Builder meuns, use the following syntax:

{ compound- nenui t em webui | | ocat i on=XXXX| key=YYYY| capti on=webui i nk}

For example, here's the markup used for the podcasting plugin:

Podcast Page Tab

{ conpound- nenui t em webui | | ocati on=syst em page| key=podcast - epi sode- page- webui | capti on=Edi t
Podcast }

Podcast News Item Tab
{ compound- nenui t em webui | | ocati on=syst em news| key=podcast - epi sode- bl ogpost - webui | capt i on=Edi t

Podcast }

Podcast Channels Space Tab



{ conmpound- nenui t em webui | | ocati on=syst em space| key=space- podcast - channel - webui | capt i on=Podcast
Channel s}

Note: There are aliases for these links in the table further up the page, the links shown above are just to illustrate how to manually
construct those links.

If you don't specify any link text (eg. "Edit Podcast") then the default text supplied by the plugins' Web Ul link will be used.

5 Important

Many third party plugins don't do strict checking of the mode and context to determine whether a Web Ul link should be displayed.
Because Theme Builder can display Web Ul links in any area of Confluence, you might need to use the builder-show macro or builde
r-hide macro to show/hide Web Ul links that start appearing in too many places.

If you need a technical explanation as to why this is the case, or any help with working with Web Ul links in third party plugins,
please contact our support desk.

When using the menulink inside a menu, it needs to be wrapped in the menuitem macro, eg:

{ conpound- menui t em webui | | ocati on=syst em space| key=space- podcast - channel - webui | capti on=Podcast
Channel s}

Hints and Tips

You can create keyboard shortcuts by adding empty menulinks to a panel in builder (eg. title or footnotes panel, etc), for example:
{compound-nenuitemedit|tooltip=Edit this content|accesskey=e|caption=Edit this %age%
This would add the keyboard shortcut "Alt+E" to all screens that can be edited (eg. blogposts, pages, etc). The shortcut would only be available if the

current user has sufficient privileges to edit the page, etc.

Share Menu

To include the Share menu, you can make a Link Alias called, say, sharepage for Share Page - Share then reference that in the macro e.g. {compound-
menuitem:sharepage...}
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